• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Couldn't find device!
Anyone get a "Couldn't find device!" error when trying to flash a program to one of the Alchitry boards (in my case a Cu)?
Sometimes I get "Couldn't find device!" and sometimes I get:

org.usb4java.LibUsbException: USB error 5: LibUsb.open() failed: Entity not found
at com.alchitry.labs.hardware.usb.UsbDevice.usbFindAll(UsbDevice.java:218)
at com.alchitry.labs.hardware.usb.UsbUtil.getDevice(UsbUtil.java:46)
at com.alchitry.labs.hardware.usb.UsbUtil.openFtdiDevice(UsbUtil.java:91)
at com.alchitry.labs.hardware.loaders.CuLoader.program(CuLoader.java:45)
at com.alchitry.labs.hardware.loaders.ProjectLoader.load(ProjectLoader.java:48)
at com.alchitry.labs.project.Project$8.run(Project.java:1539)

I have tried two different USB-C cables, both confirmed to be data cables and every single USB port and hub on my PC.
I wanted to double-check that the driver process was done correctly so I went through and took a look:
[Image: tBQ3z1Z.png]
Both Interface 0 and 1 have the WinUSB driver and seem fine to me. So idk what else to do to troubleshoot, considering this is completely new hardware and I have almost no experience.
Did you ever find a solution to this? Just fired up my Cu and received the same error.
I ended up working with the board on a different PC, so I don't have a good answer...Maybe some conflicting USB devices on the original PC...

Forum Jump:

Users browsing this thread: 1 Guest(s)