Couldn't find device!

Anyone get a “Couldn’t find device!” error when trying to flash a program to one of the Alchitry boards (in my case a Cu)?
Sometimes I get “Couldn’t find device!” and sometimes I get:

org.usb4java.LibUsbException: USB error 5: failed: Entity not found
at com.alchitry.labs.hardware.usb.UsbDevice.usbFindAll(
at com.alchitry.labs.hardware.usb.UsbUtil.getDevice(
at com.alchitry.labs.hardware.usb.UsbUtil.openFtdiDevice(
at com.alchitry.labs.hardware.loaders.CuLoader.program(
at com.alchitry.labs.hardware.loaders.ProjectLoader.load(
at com.alchitry.labs.project.Project$

I have tried two different USB-C cables, both confirmed to be data cables and every single USB port and hub on my PC.

I wanted to double-check that the driver process was done correctly so I went through and took a look:

Both Interface 0 and 1 have the WinUSB driver and seem fine to me. So idk what else to do to troubleshoot, considering this is completely new hardware and I have almost no experience.

Did you ever find a solution to this? Just fired up my Cu and received the same error.

I ended up working with the board on a different PC, so I don’t have a good answer…Maybe some conflicting USB devices on the original PC…

it’s weird because I’ve literally just reinstalled windows - will try a few other things I guess!

update: Zadig seems to have fixed it - had some other driver than the WinUSB one. I feel like I know what I’m doing, almost!

I still get the “Couldn’t find device” Error on GNU/Linux Debian 10 even though lsusb recognizes it.

You showed the screenshot, but did you click the “reinstall drivers” button? I had to do that after I upgraded Windows.