Re-flashing a Mojo V3 board

Through my own stupidity (connecting more than one board at a time to the computer) I have clobbered the flash loader on my older Mojo v3 dev board, along with the default examples added to that original flash.

Maybe my search skills are lacking, but I cannot find either the original flash file, or instructions on how to flash a board that is not responding to USB. I am guessing I am going to have to add pins to the JTag and connect and refresh that way?

Any help would be greatly appreciated.


Hey MH,

You can use the Arduino IDE to reprogram the Mojo’s flash. See

Note that you need to use version 1.6.5 of the Arduino IDE. They made some major changes that breaks things after that.


Thanks alchitry. I will give this a shot. I am dubious though, as the board is not even recognized as a legit device when connected to my Windows machine.

Off to experiment. I appreciate the answer. Maybe a good stepping stone. I will report back if success.


There are so many pages and files I am nit sure of what I am doing anymore.

Can I use the USB port to program the loader, or do I have to have some kind of “programmer” (which I do not own) and solder to the pins on the bottom of the board t be successful? I have tried a number of things in the tangle of pages here and the documentation is not always clear. For example, a number of times you say to extract the zip files into a folder you ask us to create, only to have the ZIP file expand just one folder with the files in there inside the folder you said to create. Am I supposed to just leave that folder in the folder I created, or move all the files in the ZIP folder into the new folder I created? It seems to be the second, but I have no way of knowing for sure if that may be a fail point.

Frustrating trying to understand the multiple threads of working with this board, and trying to get it re-working again. Seriously, the docs have me jumping between 5 to 7 pages. And of course, they really do not know about the content that took me to a specific page or from a specific page, so sone things may not apply.

In any case, all roads seem to point to soldering a programmer to the bottom of the Mojo board. I have no such device, and right now, I am not willing to purchase anything else. Seems like a waste because I have zero confidence this will work. This worked once, now it seems dead. Most likely I will simply toss this board and its shields into the recycle and move on if I cannot restore it.

Thanks anyway…

Hey MH,

You shouldn’t be able to nuke the bootloader without an external programmer. With an intact bootloader, you shouldn’t need a programmer to update the main code.

Try connecting it to your computer and jumping the reset pins on the back. This will cause it to enter the bootloader mode.

The two left pads are the ones you need to temporarily connect to reset the board into bootloader mode.

If your computer still doesn’t recognize the board you may have a bigger issue.

On a side note, do you have a genuine board or did you get a knock off one? The key visual factors are genuine ones have green silkscreen and our logo (the e in the chip) on the front.

If your board doesn’t look like this, it is a knock off and I make no guarantees the parts work or are even the correct ones.

Thank you. Yes, that is the board I have. I tired the reset without success. The Windows machine does not even recognize the USB device.

I really have not done much with it but lay with the clock shield and do some FPGA experimenting. It was left connected to my machine while I was programming some Arduinos. On one program I noted they Arduino did not take the program. That is when I noticed that my Clock Shied was out. When I tried to connect to the board again it failed to respond.

I guess it is possible that something failed.

Appreciate the help. Sorry for the frustration.


If you would like, you can send it into us for repair. Send me an email at with your address and I’ll get an RMA started.