Mojo-ide issue

[color=#222222][size=small][font=Arial, Helvetica, sans-serif]I have a Mojo v3 board. I have set up the Xilinx ISE and installed Mojo-ide on [/font][/size][/color][color=#222222][size=small][font=Arial, Helvetica, sans-serif]Ubuntu 19.10 running in a VM on a Toshiba Laptop.[/font][/size][/color]

[color=#222222][size=small][font=Arial, Helvetica, sans-serif]The Xilinx software runs fine. I have been doing exercises from Simon Monk’s book “Programming FPGAs”[/font][/size][/color]
[color=#222222][size=small][font=Arial, Helvetica, sans-serif]The Mojo-ide seems to work Ok I created a Project using the LEDtoButton Lucid file. I click on the mojo_top.luc and the file is displayed. I have setup the ISE location.[/font][/size][/color]

[color=#222222][size=small][font=Arial, Helvetica, sans-serif]But when I attempt to build the project by selecting the hammer icon, after a few lines I get the following error message on the console in mojo-ide[/font][/size][/color]
[color=#222222][size=small][font=Arial, Helvetica, sans-serif]“application: specific initialization failed: couldn’t load file “”: cannot open shared object file: No such file or directory”[/font][/size][/color]

[color=#222222][size=small][font=Arial, Helvetica, sans-serif]After using $sudo find command, these files exist on the ubuntu VM.[/font][/size][/color]
[color=#222222][size=small][font=Arial, Helvetica, sans-serif]I have tried to google a solution without success [/font][/size][/color]
[color=#222222][size=small][font=Arial, Helvetica, sans-serif]I think it is a path problem but I can’t figure it out.[/font][/size][/color]
[color=#222222][size=small][font=Arial, Helvetica, sans-serif]Any help would be much appreciated.[/font][/size][/color]

Initial Problem Solved.
I simply installed libncurses5.
mojo-ide seems to have built “LedtoButton” Project. After build got message “Finished Building project”
I flashed .bin file to Mojo. Got message Connecting, Loading to RAM then Done. I tested the program on the Mojo board and it worked

All seems to be working except when I look back at terminal window I see
(SWT:1938):Glib-CRITICAL **:02:09:49.215: Source ID 413 was not found when attempting to remove it
This line repeats many times. It dosn’t seem to effect the program.

Is this an issue that needs to be resolved??