cu_top_0_bitmap not found

Tried to build 1st example for a Cu board using Lucid when I got this error:

Bin file (C:\Users\David\Documents\alchitry\CuLEDtoButton\work\alchitry_imp\sbt\outputs\bitmap\cu_top_0_bitmap.bin) could not be found! The build probably failed.

I see in the forum where one fellow seemed to solve the problem but he wasn’t kind enough to provide the solution!!!

This should be fixed in 1.2.6. If not let me know.

I’m using 1.2.6 on Windows 7.

Also when I run the 1st Au project it works. However, the only output I get in the bottom frame is …

Starting Vivado…

Finished building project.

I’m expecting more logging output there!

Also, I can run build.cmd for thr Cu project from a command window and that works.

This is an update to help anyone experiencing the same problem.

I was able to build and load using this procedure:

  1. create a project in Alchitry Labs
  2. build - this fails
  3. from the project work directory run build.cmd in a command window - this works
  4. if you try to load form Alchitry Labs now it still can’t find the bin file even though it was created in step 3 and it exists
  5. Use the Alchitry Loader tool in the Alchitry installation directories. Note that the web site states that Alchitry Loader has been moved to Alchitry Labs, but it still exists standalone in the Alchitry installation direcories. The Alchitry Labs program may need to be closed before using the loader - I didn’t test this.

I just tried a clean install of iCEcube2 2020-12 on Windows 10 with Alchitry Labs 1.2.6 and it worked without issue. I did have to allow some exe’s to run when I did my first build (Window’s security prompt). Do you get any other messages when trying to build for the Cu?

Make sure for Vivado you have 2020.2 and not 2020.3 installed. 2020.3 doesn’t support the Artix 7.

No, I don’t get any other messages.

It always worked for Au and Vivado.

Just one more comment regarding my manual method as described above.

After building (manually) for Cu, the work directory was locked, and therefore I could not rebuild from Alchitry Labs. Recall that building Cu from Labs only created the build files (e.g. Verilog files and build.cmd and who knows what else). Because Labs is trying to delete the work when it rebuilds, it failed the rebuild.

I discovered that it was locked by the Lattice program C:\lscc\iCEcube2.2017.08\sbt_backend\bin\win32\opt\oaFSLockD.exe which remained as a task after the manual build. So I renamed that program and it doesn’t seem to cause a problem and it fixes the lock problem.

I just remembered that I’m using iCEcube2 2017.08, but I started with the latest version and that failed when I started out. I moved to 2017.08 because that version is shown on your installation web page and I thought it might help to use the version shown there. But, alas, I had the same problem.