Could not detect an Au!

I have setup Alchitry Labs 1.2.1 on my Windows 10 machine. I have connected Au to the machine and under UBS Controllers in Device Managers, I do see 2 entries - USB Serial Converter A and USB Serial Converter B. Both of them show the driver being used as FTDI.

Even after this, both Alchitry Labs and Alchitry Loader do not recognize this and the status is always - ‘Could not detect an Au!’ when I try flashing on to the device.

I did uninstall the devices from Device Manager with the Option for ‘Uninstall Drivers’ set to on. But after I disconnect and connect Au to the PC, the default it took was the same FTDI with no change.

Is there anything else I need to do make Alchitry Labs and Loader recognize the Au?

It should just work without having to do anything on Windows.

You could try updating Java if you are running something old. Probably not the problem but worth a try

You can also check that your board is showing up correctly by using FTDI’s utility FT_PROG

Run this, then go to DEVICES->Scan and Parse

You should see something like the attached shot. Basically check the product description is “Alchitry Au” as this is used to detect the board.

The Product Description after I run the FT_Prog is ‘USB ↔ Serial Converter’ and not Alchitry Au.
I tried connecting this to a Linux machine and when I connect, the Au is recognized as ‘RS232-HC’ on Linux.

Does this mean that I need to buy a new one and not be able to use this one?

I used the same FT Prog utility to rename the Product Description to Alchitry Au and now I can flash using both Alchitry Labs and Alchitry Loader.

Thanks very much for your help

This makes me think SparkFun may have missed programming the FTDI chip. Did your board turn on with the LED wave pattern when you first got it?

I attached the FT_PROG config for the Au so you can flash it to factory settings.

Connect the board and detect it like before but then go to FILE->Open Template and open the attached file.

Then click the lightning bolt and click Program to flash it.

You can then do another “Scan and Parse” to make sure it shows up correctly.

When I connect my Au to the PC, the LED wave pattern does show up and also blinks the alternate LEDs when I press the switch. But it did not recognize the device.

Thanks for the template file. I have programmed my device with this template file and I can flash my device now using Alchitry Labs and Loader.

I don’t follow. You said it doesn’t recognize it but you can program it? Are you still having problems?

This was resolved long time ago with the template file that you provided.
Sorry for the confusion in my reply. I was replying to your question first and then added that it was fixed with the template file.

I am having the same issue with an Au board. The board comes up flashing the lights. Under tools the serial monitor detects a board, but when I try to program it gives me “Could not detect an Alchitry Au!” I see the attached template file but do not see a way to use it with Alchiitry Labs.