Could not detect a Mojo! Win10 64Bit

Good morning,
Sorry for all these replies to posts I made earlier but didn’t have write access before.

Let’s get to the problem:
In win10 64bit alchitry labs or alchitry loader fail to detect mojo v3:

  • or by reporting “Could not detect a Mojo!”
  • or reporting a java error I think related to libusb libraries.

Mojo loader works fine however and loads .bin files correctly.

I tried all libusb drivers using zadig and only once the card was identified correctly and I could load the .bin file. (I was no longer able to recreate this situation)
When the PC was restarted, the card was not found again.
The exact same thing happens to me on the laptop always with win10 64bit but with intel architecture.

Mojo loader works fine however and loads .bin files correctly.

Under Linux Mint 2020 the card is detected perfectly and the .bin file loads smoothly and the serial port works too.

Is there a solution I can use to fix the problem?


I think I have at least partially solved the connection failure problem but I did not understand what was causing the problem.

I installed jdk-15.0.1_windows-x64_bin.exe and reinstalled jre-8u271-windows-x64.exe.

I disabled the native serial port on the motherboard and reinstalled mojo driver v3.

Now I have access to the FPGA both to write the .bin file and to use the serial port.

I also tried to restart the pc everything works if I don’t remove the usb plug.

If I do this, the mojo is detected in the device manager but with the com port number changed (Ex: COM4 first to COM16 later) in this case alchitry no longer detects the device and you need to restart the pc to restore the operation of the port by reporting the number of COM4.

With the motherboard’s native com1 port the mojo is assigned a high port number by com12 or more, and this stops alchitry-lab from working.

i don’t know if this causes the problem.

but it is certain that there is a problem identifying the com port.

With mojo loader I have never encountered problems even swapping USB port.

I do further tests to better understand what causes the problem.

Now that I understand the situation better I do the same tests on the laptop which shows the same problem even though it has no built-in com ports.

It seems that alchitry does not release the device once it is closed so that by removing the usb plug and reconnecting in the same port it now keeps the com number but alchitry lab no longer works anyway.

Mojo loader however also works in this case. But!!!
I did another test:

  • I have enabled native com on the motherboard (COM1)
  • I fixed the COM4 for mojo from the driver.

The mojo is detected and works correctly in alchitry-lab if I do not remove the usb plug by changing the port or reconnecting it to it.

-I changed usb port, reinstalled driver for mojo and fixed by COM3 driver, restarted the pc and alchitry-lab works.
But I can’t change the USB port otherwise the problem recurs, and to fix things I have to restart the pc.

That’s all I think the problem is now pretty clear.

I did the same tests on the laptop and getting Alchitry-Labs to work was more difficult.
Even if it has all the problems encountered on the desktop pc.

I noticed that if I change the USB port and then active in this case in Mojo loader it does not automatically identify the COM port but reports the one used previously even if no longer available in the system then I choose the correct port manually and everything works fine.
Isn’t it that the same logic is reported in alchitry?

Now I would like to make a suggestion:

  • it is not possible to reintroduce the possibility of manually choosing the door under alchitry-Labs? so i think we can eliminate the problem.

Thanks, I hope I was clear :wink: