• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Alchitry Cu Doesn't work with latest ICE2
#1
It would appear the latest version (December 2020) of the Lattice iCEcube2 does not work with the Alchitry Labs application.    Lattice removed the Active-HDL component, and I perhaps a few other changes.

The new version:  
https://www.latticesemi.com/Products/Des...S/iCEcube2

You can download the previous version (2017) from the archive section:

https://www.latticesemi.com/support/softwarearchive

I'm guessing this is a known problem, but it isn't mentioned on the install page.

"iCEcube2 Version 2020.12
  • Replaced Aldec™ Active-HDL™ with Mentor® ModelSim® Lattice FPGA Edition. Active-HDL Lattice Edition is still supported but not included."


Jeff Sponaugle
  Reply
#2
(02-12-2021, 03:42 AM)sponaugle Wrote: It would appear the latest version (December 2020) of the Lattice iCEcube2 does not work with the Alchitry Labs application.    Lattice removed the Active-HDL component, and I perhaps a few other changes.

The new version:  
https://www.latticesemi.com/Products/Des...S/iCEcube2

You can download the previous version (2017) from the archive section:

https://www.latticesemi.com/support/softwarearchive

I'm guessing this is a known problem, but it isn't mentioned on the install page.

"iCEcube2 Version 2020.12
  • Replaced Aldec™ Active-HDL™ with Mentor® ModelSim® Lattice FPGA Edition. Active-HDL Lattice Edition is still supported but not included."


Jeff Sponaugle

I just ran head first into this issue. 

Took me a few days to figure out that Aldec was missing from the ice install. Thanks for the archive link. Did not think about getting it from there, was trying to download directly from Aldec.

Still can't build directly from the Alchitry IDE, but at least I can build from the command line.

Please Alchitry fix this. You promise to be a beginner friendly place....
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)