11.04.2023

Hello World — Using Microblaze
Softcore

In this tutorial we will create a Vivado project and add a MicroBlaze softcore. For the programming of
the softcore we will use Vitis. Later on we will load the program to the flash of the FPGA. If we are
successful, we will receive “Hello World” on our terminal program.

Tools we need:
e Alchitry AU
USB-C Cable
Vivado 2022.2
Vitis 2022.2
Alchitry Loader 1.0
A terminal program of your choice
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Part one: Creating the Block Design in Vivado

Create a new Project
Open VIVADO and create a new Project by clicking on ,,Create Project”

VIVADO'

ML Editions

Quick Start

Create Project >
Open Project >

Cpen Example Project >

On the next page specify project name and location.

Project Name

Enter a name for your project and specify a directory where the praject data files will be stored.

Project name SimpleMicroBlaze
Projectlocation: F:/Workspace_Vivado/

Create project subdirectory

Project will be created at: F/Workspace_Vivado/SimpleMicroBlaze

Next we select RTL Project and ,,Do not specify sources at this time“, as we have no source file at this
moment.

(@) RTL Project
"~ Youwill be able to add sources, create block designs in IP Integrator, generate IP, run RTL analysis, synthesis, implementation, design planning and analysis.
Do not specify sources at this time

C] Projectis an extensible Vitis platform

Than we have to select our FPGA. The Alchitry Au—Board is using the ,Xc7a35tftg256-1“

Search: | O~ xc7als * | (30 matches)

Part /2 Pin Count  Awvailable I0Bs  LUT Elements
%C7a3btitg256-1 256 170 20800
¥CcTa3bticpg236-1L 236 106 20800
¥cT7a3bticsg324-1L 324 210 20800

Click on ,finish”.

After some seconds you should see the Vivado develop environment.

- sim F./Workspace Vivado

MicroBlsze/SimpleMicroBlsz

Fle Edt Flow Tools Reporis Window Layout View Help | ©

2 0% Project summary
& settings.
Q T & + % Overview | Dashooard
Ada Sources.
Design s
Language Templates S constans Sotigs Edt
F 1P Catalog ¥ Simuiation Sources Frojectname. SimpleticroBlaze
im_t Projectiocation Fiorkspace_Vivado/SimplebicroBlaze
¥ IPINTEGRATOR > = Utity Sources e ——
Create Block Design Projectpart 7335102561
Top mocule name: ot defined
Target language: Verlog
Simulator language:  Mired
v SIMULATION . . . . . .
Synthesis Implementation
Run Simulation Hierarchy | Libraries  Compile Order
status: Notstarted Status:
v RTLANALYSIS Propertios. ?-0ox Messages: No errors or warnings. Hessages:
> Open Elsborated Design o RE CEEEETES) R
Strategy. Vivado Syntnesis Defaults Stateay
Vivado Sy
v syNTHESIS
A Incremental implementation
» RunSyninesi
> Opens,
DRC Violations. Timing
. o see prop:
¥ WPLENENTATION Run Implementation to see DRC results Runimpl
» Runimplementation
> utization Power
~ PROGRAM AND DEBUG
15 Generate Bitstream TelConsole | Messages |Log | Reports | DesignRuns  x
> Open Hardware Manager %
Constraints  Status, WNS TNS WHS THS WBSS TPWS TotalPower FaledRoutes Metiodology ROAScore QoR‘Suggestions LUT FF |
v [ st consts_i  Notstarted
ImpL1 constrs 1 Notstarteg
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Creating the Block Design
In Vivado the block design is used to create the top file by using graphic blocks. In the Project
Manager we click on ,Create Block Design”.

Flow Navigator = 8 ? _
~ PROJECT MANAGER
£ Settings
Add Sources
Language Templates

¥ |P Catalog

v |PINTEGRATOR
Create Block Design
Open Block Design

Generate Block Design

On the next dialog we just click on ,, OK“.

¢ Create Block Design X
Please specify name of block design. ‘
Design name: design_1 |
Directory: » =Local to Project= hd
Specify source set: Design Sources w

(2)
(2) oK cancel

Now you see the empty diagram.

Diagram
iw oo O + B + C = Dofaull View W

. +

As Vivado tells us, you can add IP Blocks by clicking on the plus “Add IP”. For our design we need:

MicroBlaze

MicroBlaze Debug Module (MDM)
AXI Interrupt Controller

Clocking Wizard

Processor System Reset

AXI Uartlite

Add them all.

Florian Hartmann 3/15



11.04.2023

Afterwards there are all blocks lying around without any connection.

Diagram » Address Editor x| Address Map b4
e I x © Q + E * C 9 Default View v
# Designer Assistance available. Run Block Automation Run Connection Automation
proc_sys_reset 0 axi inte 0
11
showest_syne clk mb_rasat Clk—WIZ—O - S ted
- ax
axt_rasal_in bus_struct_resel0:0] - -
resat olk_out1 5 axi_aclk
aus_resal_in peripharal_raset]0:0] interrupt + |||
. olk_in1 lackad & axi_aresaln
mb_debug sys rst interconnect_arasatnl0:0] A
dem_locked peripharal_aresein[0:0] int0:0]

Clocking Wizard

AXI Interrupt Controller

Processor System Reset

mdm_0

microblaze_0

MBDEBUG 0 4 ||

lIl+ mTERRUPT

lll+ oesus M- Bl o= pLMB 4 |||
MicroBlaze Debug Module (MDM) ;L:et |Cro aze e + |||

MicroB laze

Some of these blocks need configurations to make. Luckily Vivado helps us here. Click on “Run Block

Automation”.

You can see, our MicroBlaze needs some configuration. Please give it 64KB of Local Memory.
preselected 8KB are not enough for the “printf” command which we need later. Even the
optimized “xil_printf” will not fit in 8KB of local memory.

The
size

¢ Run Block Automation
Automatically make connections in your design by checking the boxes of the blocks to connect. Select a block on the left to display its configuration options on the right.
- | &
Q = 2 Description
vy Aﬂ:\ﬂmmatmn (1 outof 1 selected) MicroBlaze connection autornation generates local memory of selected size, and caches can be configured.
] ¥+ microblaze_0 MicroBlaze Debug Module, Peripheral AXI Interconnect, Interrupt Controller, a clock source, Processor System Reset
are added and connected as needed. A preset MicroBlaze configuration can also be selected.
Information about the options can be found in the tooltips.
Options
Preset Naone ~
Local Memaory B64KB -
Local Memory ECC Mone “
Cache Configuration None v
Debug Module Debys Antbe —
Select the MicroBlaze cache size in kilobytes, ranging from 4KB to 64KB.
Peripheral AXI Port Enab Selecting None disables the caches and the AX] cache interfaces. Larger caches
- give better performance, but use more on-chip memaory.
|_| Interrupt Controller
) You can open the MicroBlaze Configuration Wizard after running the automation
Clock Connection Jelk_V to choose other cache sizes.
=

After clicking on “OK” you can see that Vivado created some connections.

Next click on “Run Connection Automation” and select all and quit with “OK”".
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§  Rum Connection Automation =

Autormiatically make connecions in your Sesign By checking the boues of the inberfaces 1o conned. Seled an inlertacs on ™e el b display its configuration oplons on
et right

a = &
< ' I &ulom3bion (5 out of 6 selacted)
w ) W ad_jinie_0
o5 am
w b T xa_uarsite_0
o] {5 _Am
o) L UART
= bl W dlk_wiz 0
) = oli_in1
| = radel
w | W proc_sys_reset 0
o] = ad_reset_in

N o

Vivado did a great job! Almost everything is now connected. However, our interrupt line is missing. If
the AXI Uartlite receives a signal it will generate an interrupt flag. We are not using the receiving
function in this tutorial. However, | am sure you will use it later.

So, connect the interrupt output of the AXI Uartlite with the AXI Interrupt Controller:

axi_uartlite_0

|+ §_AXI
- UART ‘ 1
&_axi_aclk + |I
interrupt

—————0 = _axi_areseln

axi_intc_0
AXI Uarlite ck_wiz 0
proc_sys_reset 0
slowest_sync_clk mb_resel
axt_rasel_in bus_struct_rasalD:0] m— n -
- l_ '_ha I_ ‘:u::: Clocking Wizard
aux_resal_in aripharal_rasat[0:
tuihecadd [fen - ~ AX] Interrupt Controller
mb_debug_sys_rst intarconnact_arasatn(0:0] e
A sl E i 1l

Connect the AXI Interrupt Controller with the MicroBlaze itself.

axi_intc_0

W It s ax
k_out1 5 axi_ack
interrupt - ||| —
lockad 5 axi_aresetn
intrf0:0]
Vizard

AX] Interrupt Controller

microblaze_0
| + INTERRUPT

-
Il ’ ) P oime |||

™ MicroBlaze @ = |—H
Resat - )

MicroBlaze
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Our diagram is finish and should look like this:
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mam_1

ret_ck_wiz_1_1D0M

mieroblaze_0

WeDERUG.D |
Den 1S Rt

tmsst_a_D

McraBiaze Debug Modue [MOM)

ah 100z [

|+ wresmuer

MicroBlaze *

oo+

icrabiaze_0_ex_perigh

b

1111

1

St s e
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micreblaze @ loval memory
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et 4
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Now, that we have our diagram, we need one more step to generate our top file. Therefore right click

on Design_1->Create HDL Wrapper...

Sources

x Design Signals ? 00
QT ¢+ 2
w Design Sources (1)

"] design
> Constraints Source Mode Properties... Strg+E
v Simulation 5 = Open File Alt-C
> sim_11(1

Utility Source.

Create HDL Wrapper...

R

View Instantiation Template

T anmrats Cudbnod Dracdoede

This wrapper translates the diagram to the top file with its Verilog design and automaticly keeps it up

to date.

% You can either add or copy the HOL wrapper file to the project. Use copy
-‘ option if you would like to maodify this file. '

Options

3:: ::1 Copy generated wrapper to allow user edits

(®) Let vivado manage wrapper and auto-update

I/'_:‘\I
\.7) OK Cancel

In the Sources-Window you can see why the call it wrapper:

Sources » Design

a = % +

b Design Sources (1)

Signals ?

~ @ = design_1_wrapper (design_1_wrapperv) (1)
~ = [8 design_1_i: design_1 (design_1.bd) (1)
> @ design_1 (design_1v) (9)
> Constraints
hd Simulation Sources (1)
¥ sim_1(1)
> Ltility Sources
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If you open the design_1.v, you can see the typical Verilog design of the top file:

module design 1
{clk_lO0MHz,
reset_rtl 0,
uart_rtl 0_rxd,
uart_rtl_0_txd);
(% X _INTERFACE INFO = "xilinx.com:signal:cleck:1.0 1
(% ¥ _INTERFACE INFO = "xilinx.com:signal:reset:1.0 ]
(* ¥_INTERFACE INFO = "xilinx.com:interface:uart:1.!
(% ¥ _INTERFACE INFO = "xilinx.com:interface:uart:1.!

N N R
PR

e

wire axi_intc_0_interrupt_ INTERRUFT;
wire axi uartlite 0_UART ExD;
wire axi_uartlite_0_UART_TxD;
wire axi uartlite 0 interrupt;

[n

Adding Constraints

Now that our block diagram and top file are finished, we need a constraint file to specify our inputs
and outputs.

Right click on Constr_1->Add Sources...

Sources  x« Design Signals ? 0
Qa = & +
~ Design Sources (1)

« @ 2 design_1_wrapper (design_1_wrappe

w o [E design_1_i: design_1 (desion_1.bd)

> @ design_1 (design_1.v) (9)
v Constraints
constrs,
" Simulation ! Constraint Set Properties...
> sim_11( Hierarchy Update b

» [ Utility Soure (> Refresh Hierarchy

_______________ IP Hierarchy o
Hierarchy IF £
Constraint Set Pri Copy Constraints Set... b
Edit Constraints Sets...
constrs_1
Edit Simulation Sets...
Default directory! & add Sources Alt+A T
File count: Report IP Status
Format: xDC

On the next windows please create a new file.

Specify constraint set: constrs_1 (agtivel LV
¢ Create Constraints File *
+A
Create a new constraints file and add it to
your project
File type I ¥DC w

File name: | Alchitr |

Filg location: | = =Local to Project= v
=
| Add Files || Create File |
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Open Alchitry.xdc and add these lines:
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set_property
set_property
set_property
set_property

set_property
set_property
set_property
set_property

set_property
set_property
set_property
set_property

PACKAGE_PIN N14 [get_ports clk 100MHz]
IOSTANDARD LVCMOS33 [get_ports clk_10@MHz]
PACKAGE_PIN P6 [get_ports reset_rtl 0]
TOSTANDARD LVCMOS33 [get_ports reset_rtl 0]

BITSTREAM.GENERAL.COMPRESS TRUE [current_design]
BITSTREAM.CONFIG.CONFIGRATE 33 [current_design]
CONFIG_VOLTAGE 3.3 [current_design]

CFGBVS VCCO [current_design]

PACKAGE_PIN P15 [get_ports uart_rtl 0 rxd]
PACKAGE_PIN P16 [get_ports uart_rtl 0 _txd]
TOSTANDARD LVCMOS33 [get_ports uart_rtl 0 rxd]
IOSTANDARD LVCMOS33 [get ports uart rtl 0 txd]

| guess these lines are not unfamiliar to you ...

And done!

Generate Bitstream
The last step in Vivado is to generate a bitstream. In the Flow Navigator click on “Generate Bitstream”

* PROGRAM AND DEBUG

¥ Generate Bitstream

» (Open Hardware Manager

In the top right corner you can see what Vivado is doing at the moment. Synthesis, Implementation,
... and after some minutes it will state “write_bitstream Complete”.

write_bitstream Complete  «/

Now, we have to export our hardware design, so that we can use it in VITIS. Click on

File->Export->Export Hardware Platform.

VIVADO!

ML Editions

& XILINX

¢ Export Hardware Platform X

Export Hardware Platform

This wizard will guide you through the export of a hardware
plafform for use in the Vitis or PetaLinux software tools.

To export a hardware platform, you will need to provide a

name and location for the exported file and specify the
platform properties.

Select “Include bitstream”.
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¢ Export Hardware Platform

Output

Setthe platform properies to inform downstream tools of the intended use of the target
platform’s hardware design.

) Pre-synthesis
" This platform includes a hardware specification for downstream software tools.

/

@ Include bitstream

to the hardware specification for software tools.

This platform includes the complete hardware implementation and bitstream, in additioné

On the next page you can see were the XSA file will be stored.

¢ Export Hardware Platform

Files

Enter the name of your hardware platform file, and the directory where the X3A file will be
stored.

ASAfile name: design_1_wrapper

Export to: F:MWorkspace_Vivado/SimpleMicroBlaze

The X3A will be written to; F\Workspace_Vivado\SimpleMicroBlaze\design_1_...

/

-]

‘ Finish ‘ | Cancel ‘

Click on Finish

Done!
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Part two: Writing the Program in VITIS

Create a Platform Project
First we have to create a Platform Project. Open Vitis and click on File->New->Platform Project...

) New Platform Praject

Create new platform project

Enter a name for your platform project

This wizard will guide you through creation of a platform project from the output of Vivado [Xilinx Shell Arch
you to specify options for the kernels, BSPs, as well as settings required for creating new applications. Platforr

Platform project name: | SimpleMircoBlaze_Platform|

« A platform prov
Platform System

Project Project « Asystem projec

= A domain provit

R ——

Click Next
On the next dialog we click on “Browse” and navigate to our XSA-File

wJ Create Platform from XSA X
« v o <« Workspace_Vivado » SimpleMicroBlaze v | D O SimpleMicroBlaze durchsuc...
Organisieren = Meuer Ordner ==« [ o
a" Mame Anderungsdatum Typ Grafe
SimpleMicroBlaze.cache Dateierdner
" SimpleMicroBlaze.gen Dateierdner
SimpleMicroBlaze.hw Dateiordner
| SimpleMicroBlaze.ip_user_files Dateiordner
2 SimpleMicroBlaze.runs Dateiordner
u SimpleMicroBlaze.sim Dateiordner
£ SimpleMicroBlaze.srcs Dateiordner
4 \J design_1_wrapper.xsa XSA-Datei 99 KB
-
B
Dateiname: ‘design_ﬂ_wrapper‘xsa V| xsa.dsg; bl

Click on “Finish”
In the Explorer section, we can see our Platform project.
~ & SimpleMircoBlaze_Platform (Out-of-date)
= export
= hw
= logs
[== microblaze_0
[(= resources

ﬂ platform.spr
platform.tcl

=

It is out of date. So select it, and built it. Project->Build Project.
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Create an Application Project
Second, we need our application project. Click on File->New->Application Project...
On the second dialog, we select our Hardware Platform:

Select a platform from repository | /77 Create a new platform from hardware (XSA)

Find: | | + Add ﬂ Manage
MName Board Flow Vendor Path
E* Alchity [custom] Embedded SW Dev xilinx F\Workspace_Vitis\Alchity\export\Alchity\ Alchity.x pfm
E’ Simple_Microblaze_HW [custom] Embedded SW Dev xilinx F:\Workspace_Vitis\Simple_Microblaze HW\export\Simple_Micrc
=% SimpleMircoBlaze_Platform [custom] Embedded SW Dev xilinx F\Workspace Vitis\SimpleMircoBlaze_Platform’\export\SimpleMi
E’ Tutorial_MicroBlaze [custom] Embedded SW Dev xilinx F\Workspace_Vitis\ Tutorial_MicroBlaze\export\ Tutorial_MicroBla

On the next dialog, we give it a name:

~

Application Project Details

Specify the application project name and its systern project properties

Application project name: | SimpleMicroBlazefpp

Systermn Project

Create a new system project for the application or select an existing one from the workspace 0

Select a system project S i aeienls

+ Create new...
Systern project name: | SimpleMicroBlazefpp_system

On the last Dialog, we select the template: “Hello World” and click on Finish.

w New Application Project O x

Templates
Select a template to create your project.

Available Ternplates:

Find: Hello World

w Embedded software development templates A Let's say 'Hello Warld' in C.
Dhrystone
Empty Application (C++)
Empty Application(C)
Hello Warld
IwlP Echo Server
IwlP TCP Perf Client
IwlP TCP Perf Server
IwlP UDP Perf Client
IwlP UDP Perf Server hd

@' < Back Mext > Cancel
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The helloworld.c file is located under src:

W |E| SimpleMicroBlazefpp_system [ SimpleMircoBlaze_Platform |
W :[E]: SimpleMicroBlazefpp [ standalene on microblaze 0 ]
! Includes
w2 SrC
[ helloworld.c
[R platform_config.h
[ platform.c
[n platform.h
E Iscript.id
2 _ide
“{ SimpleMicroBlazefpp.prj
& SimpleMicroBlazefpp_system.sprj

As you can see this is already a working program.
47
45 #include <stdio.h>»
49 #include "platform.h™
58 #include "xil printf.h"

51
52
53= int main()
54 {
55 init_platform();
56
57 print("Helle Worldin'r");
58 print("successfully ran Hellec World application”);
59 cleanup_platform();
68 return @;
61 }
62
Built it.
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Part three: Loading the design and the program into the flash

Now that we have our hardware design and our application software, we have to create the binary
file which we can upload to our FPGA.

Still in Vitis and still our application project selected click on Xilinx->Program Device.

A dialog opens. In the Software Configuration-Section, open the dropdown menu and click on
“Browse...” (Sometimes there is a double click necessary, otherwise the browse window will not
appear ... a bug?)

|~
Program Device
Specify the bitstream and the ELF files that reside in BRAM memory
Project: GCode_GRBL _system ~
Connection: Local ~ New
Device: | Auto Detect | Select...
Bitstream/PDl: | S{project_loc:GCode_GRBLY/ _ide/bitstream,/design_1_wrapper.bit | Search.. Browse..,

| [ Partial Bitstream

BMBM/MMI File: | S{project_loc:GCode_GREL}/_ide/bitstream/design_1_wrapper.mmi | Search... Browse...
Software Configuration

Processor ELF/MEM File to Initialize in Block RAM

microblaze_0 Browse... w

[]5kip Revision Check

Generate Program Cancel

Navigate to the elf-File and open it:

% Select ELF/MEM file X
« A <« Workspace_Vitis » SimpleMicroBlazeApp » Debug v O D Debug durchsuch...
Organisieren « Meuer Ordner S 4 i ] 9

il Name Anderungsdatum Typ Grafe

& src 11.04.2023 21:28 Dateiordner

| | | SimpleMicroBlazeApp.elf 11.04.2023 21:28 ELF-Datei 103 KB

£

|

oY

Dateinarme: |Simp|eMicroB|azeApp.elf v| *.elf ~

Click on “Generate”
Software Configuration
Processor ELF/MEM File to Initialize in Block RAM
microblaze 0 F\Workspace_Vitis\SimpleMicroBlazeApp'DebughSi...

[ Skip Revision Check

Generate Cancel

Now our bitstream is ready to upload into our FPGA. So connect your Alchitry-Board to your
computer. But before we upload it, let us start our terminal program and connect to our
Alchitry-Board. As you have seen in helloworld.c it will only send once “Hello World”. | do want to
miss it.
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ot HTerm 0.8.9 - [hterm.cfg]

File Options View Help

Disconnect Port | COM3 ~| R Baud Data |8 ~| Stop|1 | Party None ~ | []CTSFlow control
Rx 0‘ Reset - TX‘ 0| Reset ‘ Count|0 = l:l Reset ‘ Newline at | CR ~ EPT:::C';

Clear received ‘ Mlasci [JHex []Dec [Bin

¢ Save output ¥

: Mewline

[JClearat [0 =

sl 2 ‘ [ Autoscrall []Show

: .. characters

Sequence Overview x

Received Data

I 5 10 15 20 25

30 35 40 45

50 55

Now we are prepared to see the “Hello World”. Open Alchitry Loader.

£ Alchitry Loader V1.0.0

— O X

|  OpenBinFile

Board: (® Alchitry Au () Alchitry Cu
Program Flash

Status:

Flash EEPROM
Erase

Program

&5 70

Click on “Open Bin File” change to “All Files” and navigate to download.bit.

11.04.2023

€3 Offnen

~

« v 4 <« Workspace_Vitis » SimpleMicroBlazeApp » _ide * bitstream £ bitstream durchsuchen
Organisieren v Meuer Ordner ==~ [H 0
m”  MName Anderungsdatum Typ Gréfe
K D design_1_wrapper.bit 11.04.2023 21:25 BIT-Datei 4T0KE
5 D design_1_wrapper.mmi 11.04.2023 21:25 MMI-Datei 6 KB
1 D download.bit 11.04.2023 21:45 BIT-Datei 47T KE
‘v
Dateiname: | download.bit v| All Files w
Click on Program:
&) Alchitry Loader V1.0.0 - | X
| F:\Workspace_Vitis\SimpleMicroBlazeApp'_ide\bitstream’\download.bi| | Open Bin File
Board: (®) Alchitry Au () Alchitry Cu Flash EEPROM
41 Pregram Flash Erase
Status: Done. Program
And .....
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o HTerm 0.8.1beta - [hterm.cfg]

File Options  View Help

| Disconnect | Port | COM3 v El Baud | 9600 v| Data s v| Stop |1 | Pparity None v/
R | 54| | Reset | |Tx| 0| | Reset ||f count| 0% 1] | Reset ||/ Newineat cR
Ascii DHex |:|Dec |:|Bir1 Save output IE' DCIear at El% Ne;:;;:ﬁw % Autosr.:r

Sequence Overview =

Florian Hartmann

Received Data

1 L 10 15 20 25 30 35 40 43 50 55 &0 65
wHello WHorldyy
Successfully ran Hello World application

Success!!
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