• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Au .bin file loads but cannot program flash
#1
Hello,

For some reason I am unable to program the .bin files generated from Vivado to flash. It appears to program the flash ok, but after power is cycled there is no 'done' LED and the board does nothing. The .bin file itself works fine if just programmed into the FPGA.

I can program the flash with examples built in Alchitry Labs and those work. It's just the .bin files from my vivado projects that I cannot program to flash.
  Reply
#2
When using Alchitry Loader to put .bin's onto the FPGA, make sure the "Program Flash" box is checked, should you want the .bin to persist in the FPGAs flash storage.
  Reply
#3
(11-20-2021, 10:20 PM)Tyrving Wrote: When using Alchitry Loader to put .bin's onto the FPGA, make sure the "Program Flash" box is checked, should you want the .bin to persist in the FPGAs flash storage.

The box is checked, and it appears to program.

.bin files that generate from the Alchitry Labs examples work just fine when programmed into flash. It's when I try using a .bin file generated directly from Vivado that it doesn't work after programming into flash.
  Reply
#4
I have done this in the past, and could not reproduce the issue - are there any unusual OS or USB things that could be causing issues?
  Reply
#5
(11-22-2021, 01:43 AM)Tyrving Wrote: I have done this in the past, and could not reproduce the issue - are there any unusual OS or USB things that could be causing issues?

As for USB or OS issues, I don't think there are any. I have various other FPGA boards here and don't have a problem programming the flash on any of them. Just the Alchitry Au.

The only major difference between my Vivado project and the example projects is the size of the .bin file - the Vivado project is much more complex and the .bin file is much larger (about 1.6MB).
  Reply
#6
(11-23-2021, 11:59 AM)kanunay Wrote:
(11-22-2021, 01:43 AM)Tyrving Wrote: I have done this in the past, and could not reproduce the issue - are there any unusual OS or USB things that could be causing issues?

As for USB or OS issues, I don't think there are any. I have various other FPGA boards here and don't have a problem programming the flash on any of them. Just the Alchitry Au.

The only major difference between my Vivado project and the example projects is the size of the .bin file - the Vivado project is much more complex and the .bin file is much larger (about 1.6MB).

Could you try building a really simple Vivado project, to keep file size low, and attempt to upload that?
  Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)