• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thermal issues? + More
#1
My backordered AU starter kit just arrived, and when I plug it in, all seems well, and the LEDs do what I expect, after waiting a sec from when I plug it in. I noticed the FPGA getting toasty, although nothing painful to touch, very quickly, and am wondering if this is expected.

Assorted questions:
The default program works fine, doing the nifty (ripple? Not sure what to call this) animation. Pressing reset will make the second LED go solid for about 1/2 second, then it will begin alternating even/odd LEDs as I assume is intended. I am guessing this is from the necessary reprogramming of the (iirc volitile sram?) LUTs from the onboard flash, but I don't know a whole lot about this.
How much current can the BR drive? I don't expect it to power a relay or anything, but this would be useful to know. Forgive me if this is in the schematic or somewhere else I should have checked before posting.
Out of curiosity, what will happen to the pick and place/other tools you purchased to manufacture the boards now that Sparkfun is doing that?
Lastly, the 7-segs on the IO element have a faint glow when board is plugged in. Normal? Product of my EMI-ridden workspace?
Also, could this EMI cause any other issues potential issues using long wires and such from the BR element later on? I'm not exaggerating about the amount of EMI, it has begun to cause issues with my USB keyboard, camera, and mouse.  I've got some ferrite chokes on the way, but patience is a virtue I do not possess.

Have a wonderful day, and a preemptive thank you!
  Reply
#2
The default file on the board is there to test out the hardware. It gets fairly toasty from the DDR controller continuously running. This is normal and not a huge deal. If you really pack the FPGA or crank the clock speeds, you may need to add a heat sink but this has never been the case for me.

The reset button reveals the state of the DDR test. The first LED is illuminated during the write and the second LED is illuminated during the read. (the read takes a lot longer in the old tests) If the contents of the entire DDR checks out, it alternates the LEDs.

The reset button is just a normal input to the FPGA. It is typically used as a reset but it doesn't have to be. In the case of the test program it is just used to show the wave pattern or DDR test results. Pressing the button does not reprogram the FPGA.

The current of each pin is a little complicated. Short answer is each pin can provide up to 10mA but the total per bank is 200mA. Long answer, read the docs here https://www.xilinx.com/support/documenta..._Sheet.pdf

The Au's power supply can supply quite a bit of power on the 3.3V rail and you should have a couple amps to use.

I'm still using the manufacturing equipment for other projects.

If you haven't programmed the FPGA, the pins default to having a weak pullup. This is likely causing the glow. If you program the board to use the IO element and it still has a weird glow, this isn't normal and you should contact SparkFun about getting it replaced/fixed.

I can't really tell you if the amount of EMI will cause issues. Maybe? Depends what you're doing and how much interference you get.
  Reply
#3
Thank you for taking the time to write all that out! Good to know all is well.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)