• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
cu_top_0_bitmap not found
(06-09-2021, 03:01 PM)alchitry Wrote: I just tried a clean install of iCEcube2 2020-12 on Windows 10 with Alchitry Labs 1.2.6 and it worked without issue. I did have to allow some exe's to run when I did my first build (Window's security prompt). Do you get any other messages when trying to build for the Cu?

Make sure for Vivado you have 2020.2 and not 2020.3 installed. 2020.3 doesn't support the Artix 7.

No, I don't get any other messages.

It always worked for Au and Vivado.

Just one more comment regarding my manual method as described above.

After building (manually) for Cu, the work directory was locked, and therefore I could not rebuild from Alchitry Labs. Recall that building Cu from Labs only created the build files (e.g. Verilog files and build.cmd and who knows what else). Because Labs is trying to delete the work when it rebuilds, it failed the rebuild.

I discovered that it was locked by the Lattice program C:\lscc\iCEcube2.2017.08\sbt_backend\bin\win32\opt\oaFSLockD.exe which remained as a task after the manual build. So I renamed that program and it doesn't seem to cause a problem and it fixes the lock problem.

I just remembered that I'm using iCEcube2 2017.08, but I started with the latest version and that failed when I started out. I moved to 2017.08 because that version is shown on your installation web page and I thought it might help to use the version shown there. But, alas, I had the same problem.

Messages In This Thread
cu_top_0_bitmap not found - by D22 - 05-11-2021, 02:36 PM
RE: cu_top_0_bitmap not found - by alchitry - 05-18-2021, 04:37 PM
RE: cu_top_0_bitmap not found - by D22 - 05-18-2021, 05:28 PM
RE: cu_top_0_bitmap not found - by D22 - 06-06-2021, 05:58 PM
RE: cu_top_0_bitmap not found - by alchitry - 06-09-2021, 03:01 PM
RE: cu_top_0_bitmap not found - by D22 - 06-09-2021, 09:57 PM

Forum Jump:

Users browsing this thread: 1 Guest(s)