• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Alchitry Labs 1.2.5 - Vivado build log not displaying
#1
I'm using AL 1.2.5 with Vivado. During the build, any Vivado log messages are not downing in the AL log pane. I even introduced a deliberate error in the XDC constraints file. Is there a setting in AL, or Vivado that can used to display the build log?

[Image: 103378451-2ec34b80-4a97-11eb-978a-ab449849b9ef.png]
  Reply
#2
What version of Vivado are you using? Does it seem like it is still running and you get the "finished" message after an appropriate amount of delay or is it very fast?
  Reply
#3
I'm using Vivado 2019.2 - not the latest version, I realize - however, the version I 've been using, thinking the cause of the log not displaying may have something to do with the latest version of Vivado not playing well with AL. The idea being to experiment with earlier versions of Vivado until the prescribed behavior was observed:

https://alchitry.com/blogs/tutorials/you...ga-project
"As the project builds you should see a bunch of text spit out. Just wait for it to finish building. It should look like this... <picture below>"

The projects are building OK ("after an appropriate amount of delay" - as you say) - just no build log displaying in the AL messages window. I can find the logs and open them separately. Sure would be nice to see them in the AL environment - even if it's an option that could be turned on/off. I realize keeping it simple is important.

Perhaps it's an ISC (Mojo) .vs Vivado (Au) thing?
MDL
  Reply
#4
What version of java do you have on your pc?

I had the same problem with mojo on a pc and saw that on the laptop where the log worked I had updated java.
  Reply
#5
(01-23-2021, 08:50 PM)tistructor Wrote: What version of java do you have on your pc?

I had the same problem with mojo on a pc and saw that on the laptop where the log worked I had updated java.

Version 1.8.0_91 according to JMC.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)