Alchitry Forums
CU board wont program - Printable Version

+- Alchitry Forums (https://forum.alchitry.com)
+-- Forum: Alchitry (https://forum.alchitry.com/forum-1.html)
+--- Forum: General Questions (https://forum.alchitry.com/forum-2.html)
+--- Thread: CU board wont program (/thread-414.html)



CU board wont program - bstaton - 03-17-2022

When I try and built the board with Alchirty Lab, I get
alchitry_imp\sbt\outputs\bitmap\cu_top_0_bitmap.bin) could not be found! The build probably failed.

I can go into the directly and run the build command and generate the bin files.  Alchirty still says it cant find them.  I can use the Alchirty Loader to flash it.


RE: CU board wont program - alchitry - 04-15-2022

Someone else had this same problem and I have yet to be able to track it down or reproduce it. Can you give me any info about your system? Java version (run "java -version" in the command line), Windows version, any anti-virus software?


RE: CU board wont program - billh - 08-27-2022

Hi. I have the same problem. I just created a new thread that's still in moderation, but it can probably be deleted. I'm running Windows 11. I have a Cu board and I'm trying to build the LEDtoButton example. It fails with "Bin file could not be found" but when I run build.cmd at the command line it works just fine. I tried disabling McAfee real time virus scanning but that didn't help. My Java version is:

C:\Users\billh>java -version
java version "1.8.0_341"
Java™ SE Runtime Environment (build 1.8.0_341-b10)
Java HotSpot™ 64-Bit Server VM (build 25.341-b10, mixed mode)


RE: CU board wont program - sfnagle - 09-27-2022

(04-15-2022, 03:23 PM)alchitry Wrote: Someone else had this same problem and I have yet to be able to track it down or reproduce it. Can you give me any info about your system? Java version (run "java -version" in the command line), Windows version, any anti-virus software?

I have this problem as well, when working through the Sparkfun Tutorial "First FPGA Project - Getting Fancy with PWM." On the other hand I had success with all parts of another, simpler tutorial "Programming an FPGA." The biggest difference is that the "First FPGA Project" tutorial uses a couple components from the Alchitry IDE, counter.luc and pwm.luc. 

Any ideas what's wrong with the PWM and/or counter code?


RE: CU board wont program - sfnagle - 09-27-2022

My recent post has not cleared moderation yet, but this is the error message:

Parsing edif file: C:/Alchitry/Pulsing_LEDs/work/alchitry_imp/cu_top_0.edf...
Error: ParseEDIF C:/Alchitry/Pulsing_LEDs/work/alchitry_imp/cu_top_0.edf failed
Kparser Unable to open C:/Alchitry/Pulsing_LEDs/work/alchitry_imp/cu_top_0.edf
child process exited abnormally
edifparser failed:CHILDSTATUS 3840 1

Bin file (C:\Alchitry\Pulsing_LEDs\work\alchitry_imp\sbt\outputs\bitmap\cu_top_0_bitmap.bin) could not be found! The build probably failed.