Alchitry Forums
Alchitry Labs not working at all - Printable Version

+- Alchitry Forums (https://forum.alchitry.com)
+-- Forum: Alchitry (https://forum.alchitry.com/forum-1.html)
+--- Forum: General Questions (https://forum.alchitry.com/forum-2.html)
+--- Thread: Alchitry Labs not working at all (/thread-343.html)



Alchitry Labs not working at all - jm.sellier - 05-12-2021

Hello,

I recently bought an Alchitry Au and I am planning to use Alchitry Labs to program it. Unfortunately, for reasons which I really can't understand, I cannot synthesis anything from this IDE. When I push the little hammer button, the IDE says "Starting Vivado..." but then it stays like this forever.

Let me provide more info below :

- I am using Vivado 2020.1 and it works perfectly with the Alchitry Au board,
- My java is updated to the latest version, i.e. 1.8.0_291-b10,
- The Alchitry Labs version is 1.2.6,
- Everything is installed on a regularly updated Windows 10 machine.

Any idea why I am not able to build anything from this IDE? Obviously, I will provide more information, if necessary, to whoever wants to help me.

Thanks!


RE: Alchitry Labs not working at all - alchitry - 05-18-2021

This seems to be a fairly common issue but I haven't been able to replicate it myself.

Do you have anything noteworthy about your installation? Is everything on the C drive?


RE: Alchitry Labs not working at all - azdev - 06-14-2021

(05-12-2021, 08:09 PM)jm.sellier Wrote: Hello,

I recently bought an Alchitry Au and I am planning to use Alchitry Labs to program it. Unfortunately, for reasons which I really can't understand, I cannot synthesis anything from this IDE. When I push the little hammer button, the IDE says "Starting Vivado..." but then it stays like this forever.

Let me provide more info below :

- I am using Vivado 2020.1 and it works perfectly with the Alchitry Au board,
- My java is updated to the latest version, i.e. 1.8.0_291-b10,
- The Alchitry Labs version is 1.2.6,
- Everything is installed on a regularly updated Windows 10 machine.

Any idea why I am not able to build anything from this IDE? Obviously, I will provide more information, if necessary, to whoever wants to help me.

Thanks!

Luckily Tyrving solved this in another thread! Just install the latest version of Java SE (NOT "NORMAL" JAVA because that is only Java 8).