Alchitry Forums
Alchitry Cu Doesn't work with latest ICE2 - Printable Version

+- Alchitry Forums (https://forum.alchitry.com)
+-- Forum: Alchitry (https://forum.alchitry.com/forum-1.html)
+--- Forum: General Questions (https://forum.alchitry.com/forum-2.html)
+--- Thread: Alchitry Cu Doesn't work with latest ICE2 (/thread-306.html)



Alchitry Cu Doesn't work with latest ICE2 - sponaugle - 02-12-2021

It would appear the latest version (December 2020) of the Lattice iCEcube2 does not work with the Alchitry Labs application.    Lattice removed the Active-HDL component, and I perhaps a few other changes.

The new version:  
https://www.latticesemi.com/Products/DesignSoftwareAndIP/FPGAandLDS/iCEcube2

You can download the previous version (2017) from the archive section:

https://www.latticesemi.com/support/softwarearchive

I'm guessing this is a known problem, but it isn't mentioned on the install page.

"iCEcube2 Version 2020.12
  • Replaced Aldec™ Active-HDL™ with Mentor® ModelSim® Lattice FPGA Edition. Active-HDL Lattice Edition is still supported but not included."


Jeff Sponaugle