Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums



(Advanced Search)

Forum Statistics
» Members: 991
» Latest member: thomasmarsden970
» Forum threads: 235
» Forum posts: 703

Full Statistics

Online Users
There are currently 19 online users.
» 0 Member(s) | 17 Guest(s)
Bing, Google

Latest Threads
Cu+iCEcube2: "[: unexpect...
Forum: General Questions
Last Post: 011010010110010001
Yesterday, 10:26 PM
» Replies: 1
» Views: 12
Any GPIO pins for SPI?
Forum: General Questions
Last Post: 011010010110010001
06-23-2022, 11:24 PM
» Replies: 0
» Views: 22
clockclock Projekt Help
Forum: General Questions
Last Post: Matze
06-18-2022, 05:36 AM
» Replies: 0
» Views: 11
Architry-Lab does not bui...
Forum: General Questions
Last Post: erich
06-08-2022, 11:25 AM
» Replies: 2
» Views: 1,530
CU - IO pin connection
Forum: General Questions
Last Post: Gina02
06-06-2022, 07:54 AM
» Replies: 2
» Views: 874
mojo v3 copy program to b...
Forum: Tips and Tricks
Last Post: mgrenier
05-09-2022, 06:15 PM
» Replies: 0
» Views: 144
Alchitry Hd, Mo, Ft
Forum: General Questions
Last Post: impalaengineer
05-07-2022, 08:40 PM
» Replies: 4
» Views: 2,299
ICEcube2 licensing on Lin...
Forum: Tips and Tricks
Last Post: Adela Abshire
04-25-2022, 04:51 AM
» Replies: 2
» Views: 2,878
quad spi flash, E8, qspi_...
Forum: General Questions
Last Post: sumbals
04-22-2022, 02:44 PM
» Replies: 1
» Views: 247
Using Virtual Machine
Forum: Tips and Tricks
Last Post: Gina02
04-22-2022, 09:58 AM
» Replies: 2
» Views: 3,007

 
  Alchitry a dying project?
Posted by: wdautrem - 04-19-2021, 06:35 PM - Forum: General Questions - Replies (2)

I'm looking to get into FPGA development and was interested in the Alchitry dev board.  Unfortunately, it looks like this product is running out of steam.  Nearly all hardware is out of stock or backordered.  No blog posts for years.  Only a hand full of forum posts this year.  No new element boards being released (HDMI board).  Am I seeing this correctly, or is there another reason for the lack of activity?


  Using Alchitry Labs with Au+
Posted by: howdyrichard - 04-18-2021, 01:11 PM - Forum: General Questions - Replies (1)

Alchitry Labs with Au+, does it work together???


  Compatible boards
Posted by: tagsense - 04-09-2021, 03:19 AM - Forum: General Questions - Replies (1)

Folks,
Greetings!


I see that none of the development boards - Alchitry CU/AU and Mojo - are available for sale.
Are there other compatible boards one can use for learning? kindly let me know. thank you!

the reason i am asking is I just got the FPGA book (Learning FPGAs: Digital Design for Beginners with Mojo and Lucid HDL).
the book uses Mojo as the FPGA development board.


  Absolutely no way to flash CU
Posted by: DMoore127 - 04-09-2021, 03:02 AM - Forum: General Questions - Replies (1)

I've been attempting to get a .bin file onto my Cu for some time now, to no avail. I'm using IceStorm for synthesis (with success), but I can't for the life of me get that bin file onto my board. Alchitry Loader immediately crashes (hangs on starting) when attempting to flash to a Cu on my instance of Ubuntu and both of my instances of Windows 10. The command line utility for MacOS can find my Cu with -l on device 0, but states it can't find a device. When I use Alchitry Labs with Ubuntu, I'm able to synthesize and construct a net list/bin file perfectly with IceStorm, but it insists that it cannot find a Cu, even though I can confirm that I see the device on ttyUSB0 and ttyUSB1.

This is starting to get quite frustrating for something that is marketed as so simple. Is there something I'm missing or something that I need to do?

For context, I'm running MacOS with Parallels for Ubuntu and one instance of Windows 10, with an instance of Windows 10 running on a desktop; all 4 to no avail.


  Alchitry Labs not playing nicely with Vivado
Posted by: Tyrving - 04-03-2021, 11:11 PM - Forum: General Questions - Replies (6)

Hello! Loving my AU, but I've been having some issues. When I first tried using Alchitry Labs, it wouldn't get past "Starting Vivado..."
I decided to just learn verilog, and use plain ol Vivado with the loader, which works fine. However, now that I find myself wanting to do more with complex AU features, like the IO module 7-segs and RAM. I dont want to design my own memory controller, and verilog has been pretty confusing - two problems I can solve via Alchitry Labs with lucid. I ported the I/O files into Vivado from Labs for the buttons/DIP row/LED row, which has been enough for my projects until now. I did some investigation through task manager, and it seems that Labs will spawn a Vivado process, which will start eating up one of my processor threads, until after a few minutes, then it will disappear. Upon cancelling the build, Labs reports there is no .bin file found in the destination directory - '\working\dir\.runs\impl_1\au_top_0.bin) could not be found! The build probably failed.' I am using Labs 1.2.6, and Vivado 2020.2. I have validated my Vivado files through help -> add design tools or devices. I have been troubleshooting with the led to button sample project. Running Windows 10.

Any help would be appreciated.

P.S. I found alchity2.com, and I gotta complement the UI design, except for the miniscule drop-down menus.


  Issue loading Vivado bins onto AU+
Posted by: Electrick - 03-31-2021, 08:28 PM - Forum: General Questions - Replies (1)

Hi all,

I just got my AU+ board in a couple of days ago, and as a career EE I was hoping to do some more advanced development with it. After dinking around with my setup for a few hours I finally got the first Lucid tutorial working, flashed to the AU+ and everything. However, when I finished up  the Verilog tutorial and loaded the bin with the alchitry-loader, the LEDs wouldn't light up at all. Also, nothing seems to happen when I press the rst button.

I also notice that when the alchitry-loader is finished flashing the board, the "DONE" LED doesn't light up like it did with the Lucid tutorial.

I'm operating on a 2015 Macbook running the latest Ubuntu 20.10 and openjdk 11.0.10

Any help would be much appreciated!


Exclamation Trouble programming Mojo v3 with Alchitry Labs (& Loader)
Posted by: gr3mlin - 03-28-2021, 01:06 PM - Forum: General Questions - Replies (7)

Good morning. I've dusted off a genuine Mojo v3 I purchased a while back and setoff determined to burn through tutorials this weekend. I've come hat in hand for help as I've exhausted every avenue I know of to troubleshoot programming the board.

My setup:
Windows 10 Pro version 2004 (latest updates) in a Parallels VM running on MacOS Big Sur 11.2.3
Parallels is set to permanently assign the Mojo device within USB settings to my Windows VM.
Windows device manager sees "Mojo V3" under Ports (COM & LPT). It's assigned to COM5 or COM3 depending on the reboot attempt.
Running Alchitry Labs v1.2.5 on the Windows VM. Installed both ways, the .msi and the zip file. Found that the zip file only contained the dpinst-amd64.exe which I ran, confirmed that the driver is installed.
Installed ISE and licensed everything, can build tutorials without any problems.
I'm running JRE 8u281 on the Windows VM.
I also attempted all steps with JDK 16 on the Windows VM before uninstalling that and just trying the JRE.
CMD java -version returns java version "1.8.0_281"

Trouble:
1) When running alchitry-loader, wether I select Erase or Program, the problem completely hangs unresponsive saying "Connecting". I can't grab the window and move it, close it, etc.
2) When running alchitry, following a successful build, an attempt to program lands me at "Connecting" in the status window.
3) Alchitry crashes when I attempt to open the Serial Port or attempt to Register Device.

I read on the forums and github that 1.2.5 was supposed to resolve the Serial Port crashing issue, and question if I have some java issue. I havn't gone so far as to attempt to edit code and debug with print statements. Hopefully someone can set me straight before going scorched earth.

Appreciate any assistance! I'm excited to get my Mojo working.


  Which Ubuntu and JRE version should I use to install Alchitry-lab ??
Posted by: wing - 03-24-2021, 05:51 PM - Forum: General Questions - Replies (2)

Hi,
  Anyone successfully install and run Alchitry-labs on Ubuntu?
I just try Ubunut 18.04, and oracle-jre 1.8.0_281,

but fail  it give that error
"Exception in thread "Thread-9" java.lang.NoSuchMethodError: java.nio.CharBuffer.flip()Ljava/nio/CharBuffer;
    at com.alchitry.labs.Util$startStreamPrinter$printer$1.run(Util.kt:501)
Exception in thread "Thread-10" java.lang.NoSuchMethodError: java.nio.CharBuffer.flip()Ljava/nio/CharBuffer;
    at com.alchitry.labs.Util$startStreamPrinter$printer$1.run(Util.kt:501)


"


Sad Alchitry-Cu first tutorial not work!
Posted by: wing - 03-21-2021, 05:09 PM - Forum: General Questions - Replies (7)

I follow the tutorial  https://alchitry.com/blogs/tutorials/you...ga-project
to test on my Cu board
and 
1. Windows 10
2. Alchitry Labs version 1.2.5
3. iCEcube2 version 2017.08

but it give the following error

Staring iceCube2...
Bin file (D:\workspace_alchitry\LEDtoButton\work\alchitry_imp\sbt\outputs\bitmap\cu_top_0_bitmap.bin) could not be found! The build probably failed.

Any suggestions ?

Thanks


  DRIVE strength and SLEW rate in Alchitry Labs
Posted by: Rory - 03-21-2021, 05:17 AM - Forum: General Questions - No Replies

Hi,
With the Mojo v3 in the old IDE, you could adjust the pin IO standard, pullup/down resistors, slew rate, and drive strength in the .ucf file as shown here.

In Alchitry Labs, you edit a .acf file, but the only allowed keyword is "pullup" or "pulldown". How do I change the DRIVE strength parameter in Alchitry Labs? 
The relevant Xilinx 7-series SelectIO document is here on page 48.

Thanks.