Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums



(Advanced Search)

Forum Statistics
» Members: 685
» Latest member: CarolineReed
» Forum threads: 189
» Forum posts: 551

Full Statistics

Online Users
There are currently 19 online users.
» 0 Member(s) | 17 Guest(s)
Bing, Google

Latest Threads
Au plus and DDR3 Tutorial
Forum: General Questions
Last Post: alchitry
09-24-2021, 04:57 PM
» Replies: 4
» Views: 508
Alchitry Labs not working...
Forum: General Questions
Last Post: mdlougheed
09-08-2021, 12:12 AM
» Replies: 3
» Views: 691
Could not detect an Au!
Forum: General Questions
Last Post: satheesh_s
07-23-2021, 01:51 AM
» Replies: 6
» Views: 2,635
LEDs on Io Breakout Board...
Forum: Tips and Tricks
Last Post: alchitry
07-22-2021, 02:35 PM
» Replies: 2
» Views: 422
Alchitry labs crashes Moj...
Forum: General Questions
Last Post: alchitry
07-22-2021, 02:33 PM
» Replies: 1
» Views: 760
DDR3 speed in example
Forum: General Questions
Last Post: alchitry
07-22-2021, 02:31 PM
» Replies: 3
» Views: 1,346
Question Shield Mojo to A...
Forum: General Questions
Last Post: alchitry
07-22-2021, 02:29 PM
» Replies: 5
» Views: 1,945
DDR3 speed of READ comman...
Forum: General Questions
Last Post: alchitry
07-22-2021, 02:27 PM
» Replies: 1
» Views: 724
Alchitry Loader - Could n...
Forum: General Questions
Last Post: alchitry
07-22-2021, 02:19 PM
» Replies: 2
» Views: 341
Constraints files
Forum: General Questions
Last Post: TechPaula
07-18-2021, 01:01 PM
» Replies: 2
» Views: 1,092

 
  Using Virtual Machine
Posted by: serge - 03-03-2019, 11:10 AM - Forum: Tips and Tricks - Replies (1)

I am currently working on a Mac OS machine and to access the Cu/Au board I am using a virtual machine running debian buster.

To get the loader to work I had to use the new one and install the udev rule (obviously, as documented), but this is not sufficient per-se.

Usually, once the VM is running I'm doing everything from the MacOS terminal by ssh-ing to the VM (to avoid to deal with the «GUI» of the VM). When doing this the loader does not work (or in a very chaotic way). In particular it would «see» the board only if it was plugged in during the boot, flashing would sometime stop and reset in the middle of the process… (I am sure it is not a «board problem» since they work perfectly well with a «real» debain buster machine).

Indeed there seems to be small compatibilities issues with vritualbox; so here are the workarounds I have found to get a working solution :

* Setting the VM to use the xHCI (USB3.0) controller (in the configuration->ports->USB)
* Opening a GUI session on the VM (even if not really using it)

With this on (the «proper» virtual USB controller, and the session being opened) I can use the loader (indeed even within my ssh session rather than the «local session within the VM»).

These indeed seems to me more problems from virtual-box than from the Alchitry software, but I guess some other might be trying to using a similar technique to work on a Mac (or other unsupported OS).

Hope this will help.


  Alchitry Cu Serial Interface
Posted by: rrc - 02-28-2019, 08:20 PM - Forum: General Questions - Replies (2)

Hi,
in the schematic I can see, that two pins of the ICE40 are connected as RxD and TxD to the FTDI chip. Is this a serial interface to communicate the FPGA?
If yes: how do I connect to on PC side? The FTDI did not appear as /dev/tty* device on my Linux machine.

-RRC


Wink Alchitry Loader on 32-bit Machines (Linux)
Posted by: rrc - 02-28-2019, 06:04 PM - Forum: Tips and Tricks - Replies (11)

For other users using the ancient 32-bit processor architecture the software package is not executable directly as it is only compiled for 64-bit computers. Fortunately it is possible to emulate such a processor with qemu-x86_64 contained by the qemu-user package in the Debian distribution. I was successfully able to upload a bitstream to my Alchitry Cu by executing

Code:
qemu-x68_64 ./tools/loader -f  test.bin
in the extracted package directory of Alchitry Loader.
I don't think that it is possible to launch the GUI easy like this. But in my usecase it is all I wanted since I use project Icestorm directly to develop my stuff on that FPGA.

-RRC

_____
Update:
For the Alchitry Cu there is a way better solution in using the iceprog tool of project IceStorm.
I was able to upload the bitstream by just executing
Code:
iceprog test.bin
This tool should be available for many devices. For Debian it is in the package fpga-icestorm


  Alchitry Cu and Io Pulldown Resistors
Posted by: Geo747 - 02-26-2019, 09:37 PM - Forum: General Questions - Replies (3)

Hey,
I've been trying to get the Io board to work with the Cu today. I'm using verilog and Icecube2 with the alchitry loader (not using the alchitry ide). I'm trying to set up a .pcf file for the IO and have all the LEDs working correctly but cant get the switches or buttons to work. I believe this is because I need to set the inputs to have pull down resistors, as per the schematic, however I cant find any documentation of the iCE40-HX8K that suggests it has pull down resistors available on its inputs. In the icecube2 pin constraints editor only pull up resistors are available, and they havent helped in my scenario. When I have the pullup enabled, I just get a constant high logic level from that pin, and when the pullup isnt enabled it has erratic behaviour and will turn on or change state when i touch the button's casing, without actually depressing the button.

If someone knows what im missing to get it to work that would be much appreciated.

Thanks,
George


  Cu - how to start?
Posted by: wing - 02-24-2019, 06:46 PM - Forum: General Questions - Replies (5)

Hi ,
   Just received the Alchitry Cu, look great.
May I ask how to get started? It seem the tutorials are still for "mojo v3" and using Xilinx tools.

Thanks
Wing


  Alchitry Io Switches with Au
Posted by: garthberry - 02-22-2019, 03:22 PM - Forum: Tips and Tricks - No Replies

After trying to get the switches (DIP and pushbutton) Alchitry Io working for a little too long it finally occurred to me that pulldowns need to be enabled for each of the pins attached to a switch. If pulldowns are not enabled the pin will typically float high. The pulldown resistor can be enabled on a pin by pin basis in the  constraints file as follows:

Code:
set_property PACKAGE_PIN C4 [get_ports {dip_sw[0]}]
set_property IOSTANDARD LVCMOS33 [get_ports {dip_sw[0]}]
set_property PULLDOWN TRUE [get_ports {dip_sw[0]}]


  Clocking with Lattice Parts
Posted by: samuelcomeau - 02-22-2019, 06:25 AM - Forum: General Questions - Replies (2)

Hey,
So with the Mojo, the way to get new clocks was to use coregen via the awesome installed button. Since Cu is a Lattice part there is obviously not a coregen option. Therefore, how do I get my higher or lower clock signal?


  Headers. (First!)
Posted by: samuelcomeau - 02-22-2019, 01:26 AM - Forum: General Questions - Replies (7)

Hey, 
So I've had the Alchitry Cu for a few days. Great looking board, I'm excited to get the software up and running. Just one question. How do I connect anything to it? I don't see my comfortable headers and I feel completely paralyzed. 
Objectively, I know there is a solution to this problem and that it wouldn't require too much work on my part, but is there a simple solution to go from the super whamadine headers to my comfortable breadboard friendly ones? 
(P.S. I don't hate the new headers, my Mojo has so many bent pins it's starting to look like a porcupine.)
-Sam


  Welcome to the new forum!
Posted by: alchitry - 02-21-2019, 05:47 PM - Forum: Announcements - No Replies

Welcome to the new forum! After the old forum was basically made useless by an overflow of spam, this new one will hopefully fare better.

Note that you will need seperate logins for the forum and our store.

You can still access the old forum in its "read only" state here https://forum.embeddedmicro.com/